Invoice Line Description not shown in GL

To err is to be human, to help each other is joy. Tell your Compiere needs in your own words. Let's figure out together.

Moderator: azaharizaman

Invoice Line Description not shown in GL

Postby Enrique » Thu Oct 07, 2004 9:40 am

Hi Red1

There is a problem with compiere version 2.51f, when you post a transaction the description line appears blank so you cannot relate the GL transaction against the source document.

There is a bug posted in Compiere sourceforge under 1030988

Although it is supposed to be fixed in 2.5.1g, I don't have the latest build, I have tryied to fix it myself and reviewed all the accounting related modules at the source, I just haven't found the right hint.

I appreciate if you could help me out with some advise

Regards,

Enrique.}
Enrique
 
Posts: 18
Joined: Thu Oct 07, 2004 9:30 am
Location: Mexico

Postby red1 » Thu Oct 07, 2004 5:01 pm

Hi Enrique.

Don't panic, amigo, we help each other.. 8)

Did u look into this java?: FactLine.java, there is a duplicate code, certainly something funny there. Hope this is hint enough. I dont have much time here, so u try to tackle from there. If not solved tell me, so i can look for more clues.
Next time use the Bugs Galore forum. I will move this to there later.


// Description
StringBuffer description = new StringBuffer(m_docVO.DocumentNo);
if (m_docLine != null)
{
description.append(" #").append(m_docLine.getLine());
if (m_docLine.getDescription() != null)
description.append(" (").append(m_docLine.getDescription()).append(")");
else if (m_docVO.Description != null && m_docVO.Description.length() > 0) description.append(" (").append(m_docVO.Description).append(")"); }
else if (m_docVO.Description != null && m_docVO.Description.length() > 0) description.append(" (").append(m_docVO.Description).append(")");
// Journal Info

These changes to codes in 251f seems to show that it is migrating the model to a Value Object pattern perhaps due to the new WorkFlow engine. Thus some typo errors such as these will occur.

Hope this help you. And I need your help here to help others too. :wink:
red1
red1
Site Admin
 
Posts: 2762
Joined: Tue Jul 06, 2004 3:01 pm
Location: Kuala Lumpur, Malaysia

NO GL Description when posting a transaction

Postby Enrique » Fri Oct 08, 2004 2:57 am

Hi red1

Thanks for your response, I have checked file facts.java and their relatives doc.java, docline.java, facline.java with no success.


I would appreciate any further help on this issue.

By the way, I am not really an expert in Compiere, but in any way I can help sure can count on me.


Regards,

Enrique Ruibal
Enrique
 
Posts: 18
Joined: Thu Oct 07, 2004 9:30 am
Location: Mexico

Postby red1 » Fri Oct 08, 2004 9:49 am

Hi Enri,
I used Eclipse yesterday and did Remote Debugging where i can step into the Accounting Codes using JBoss, its seems that what i suggested above is only beginning part. The description there is correctly passed to the program. So it must have been lost further down. I didnt go further as it will take longer time, and i hope you can continue from there and we share the story and fun :lol:

Do u know how to debug using Eclipse? Remote debug for JBoss? If not, i will write an article on how to debug this kind of specific problem. I wanted to write this Accounting Posting debugging anyway.

red1
red1
Site Admin
 
Posts: 2762
Joined: Tue Jul 06, 2004 3:01 pm
Location: Kuala Lumpur, Malaysia

Description Line Not Shown in GL

Postby Enrique » Fri Oct 08, 2004 8:27 pm

Hi Red1,

Thanks for your response, it will be very good to have a tutorial document on how to debug compiere accounting with jboss.

As for this bug i will keep searching at compiere' sourceforge to see if I can have the fix download

Regards! :lol:

Enrique R.
Enrique
 
Posts: 18
Joined: Thu Oct 07, 2004 9:30 am
Location: Mexico

Postby red1 » Fri Nov 05, 2004 11:35 pm

Hi,
This is to comment here that i have done the tutorial so pls take it at http://compiere.red1.org/RemoteDebug.zip

Pls share any code debugs adventures u have here! :)

enjoy!

red1
red1
Site Admin
 
Posts: 2762
Joined: Tue Jul 06, 2004 3:01 pm
Location: Kuala Lumpur, Malaysia

Postby Enrique » Sat Nov 06, 2004 6:24 am

Hi Red1,

Thanks again to you and Arul Mani for your worthy piece of advise! And you count on me for feedback in future compiere debugging issues..

Regards,
Enrique
Enrique
 
Posts: 18
Joined: Thu Oct 07, 2004 9:30 am
Location: Mexico


Return to Ask RED1 personally

Who is online

Users browsing this forum: No registered users and 1 guest