Period Problem

To err is to be human, to help each other is joy. Tell your Compiere needs in your own words. Let's figure out together.

Moderator: azaharizaman

Period Problem

Postby kccho » Tue Jun 21, 2005 1:11 am

Hi Red1,

I am using Compiere Version 252e now.

I want to enter a day-back Non Binding Offer (which date is 04/01/2004) and want to test the system.

When I press "Complete" button, the system don't let me pass. The status of this order is "Draft" and the left bottom corner message is "Period Closed"

I lookup the console window and there is an error message:

-----------> MPeriod.isOpen: Today after last day - 2004-03-30 00:00:00.0 [683]
-----------> MPeriod.isOpen: 04-2004: Not open for SOO (2004-04-02 00:00:00.0) [
683]
===========> MWFActivity.run: run [683]
java.lang.Exception: @PeriodClosed@
at org.compiere.wf.MWFActivity.performWork(MWFActivity.java:759)
at org.compiere.wf.MWFActivity.run(MWFActivity.java:673)
at java.lang.Thread.run(Thread.java:534)


Here is the problem, I have open all period from "Finanacial Year and Period" Window.

I done that by press button "Open/Close All" on each period.

Have I done something wrong when I want open the period?
What is the correct procedure to open a period?

Or is it kind of bugs?

Regards

kccho
kccho
 
Posts: 4
Joined: Fri Sep 03, 2004 6:38 pm

This may be a new feature in Compiere

Postby neilg » Tue Jun 21, 2005 3:31 am

I don't remember the details but there is somewhere in the accounting schema setup or somewhere where you have additional setup info regarding the periods. This has been observed in the > 2.5.2 versions. So I don't think it is a bug but rather a feature :)
neilg
Regular
 
Posts: 141
Joined: Thu Jun 16, 2005 1:58 pm

Postby red1 » Tue Jun 21, 2005 6:34 am

Can u just take the latest 252e version here and use the ImportCompiere of the data dump? Cos the data dump provided is often late or early bird for partners only. If u are not a Compiere Partner, what data dump are u using? :roll:

regards
red1
red1
Site Admin
 
Posts: 2762
Joined: Tue Jul 06, 2004 3:01 pm
Location: Kuala Lumpur, Malaysia

Postby hema » Tue Jun 21, 2005 7:45 pm

Hi kccho,

make sure that the "Automatic Period Control" field is unchecked (refer to the Accounting Schema Window).

Regards,
Hema
hema
Regular
 
Posts: 81
Joined: Wed Aug 25, 2004 5:21 pm

Postby neilg » Wed Jun 22, 2005 12:51 am

hema,

Yes thats the same solution I heard about
neilg
Regular
 
Posts: 141
Joined: Thu Jun 16, 2005 1:58 pm


Return to Ask RED1 personally

Who is online

Users browsing this forum: No registered users and 1 guest

cron