Display Logic of Process param don't work well in Swing

Help is preferred to those who publish their work as Open Source and not as private branches rejecting collaboration. Such projects are not maintainable and shall be deleted.
Forum rules
This forum is personally pruned to avoid redundant posts. Related topics are grouped together. IF YOU HAVE REGISTERED, you need to send email to red1(a)red1.org with your username in the subject title to get me to activate you.

Display Logic of Process param don't work well in Swing

Postby yansolo » Mon Sep 26, 2011 10:51 pm

Hi !

I'm currently migrating from a 360 version to the last 361 (with globalqss patches).
I've made some tests and i found out that Display Logic is mostly broken in swing mode.
When a param should be hidden, the field is hidden but not its "heading".
You can try with process "Bill of Material & Formula Cost".
Put something on Product Category.
Field "product" disappears, but no the heading. :?

It was working properly in 360.
WebUI is ok.

Thanks,

Yan
yansolo
 
Posts: 48
Joined: Tue Mar 22, 2011 9:28 pm

Re: Display Logic of Process param don't work well in Swing

Postby globalqss » Tue Sep 27, 2011 12:04 am

Thanks Yan for reporting. Reproduced in globalqss361 and iDempiere

I would not call that broken - is just a presentation issue.

Can you please open a ticket at http://jira.idempiere.com

Regards,

Carlos Ruiz
globalqss
Senior
 
Posts: 599
Joined: Thu Dec 29, 2005 4:15 am
Location: Bogotá, Colombia

Re: Display Logic of Process param don't work well in Swing

Postby yansolo » Tue Sep 27, 2011 1:51 am

done, issue 74 !
and yes, broken is a little bit too strong !

Thanks,

Yan
yansolo
 
Posts: 48
Joined: Tue Mar 22, 2011 9:28 pm


Return to HELP ME!!!

Who is online

Users browsing this forum: No registered users and 4 guests

cron