Name clash problem in c253b

Whenever bugs are encountered they are quashed and reported. Here you can see their quashings up close.

Moderators: sureshquest, arulmani, trifon

Name clash problem in c253b

Postby aries211 » Thu Apr 27, 2006 3:27 pm

Hi all,

Have you ever met this problem in c253b?

There is an error in compiere-all/dbport/src/org/compiere/util/CCachedRowSet.java

On the line of : public class CCachedRowSet extends CachedRowSetImpl implements CachedRowSet {
The error is:
"Name clash: The method setTypeMap(Map<String,Class<?>>) of type BaseRowSet has the same erasure as setTypeMap (Map) of type RowSet but does not override it "

I think it is the problem of JDK, but I do not know how to solve it.

regards!

aries
aries211
 
Posts: 11
Joined: Wed Mar 29, 2006 9:32 am
Location: China

Postby Mr_reggatta » Fri Apr 28, 2006 4:43 pm

Have you imported the rowset.jar ?!?!
Probably this is the problem.
regards
mr_reggatta
Mr_reggatta
 
Posts: 24
Joined: Wed Mar 15, 2006 12:34 am
Location: Roma, Italy

Postby aries211 » Sat Apr 29, 2006 11:08 am

Thanks for your advise, mr_reggatta

There contains rowset.jar in /compiere-all/lib/

I downloaded the latest release of rowset.jar to replace the original one and the error dispeared.

Till now there is no error in my c253b.

Rrgards!

aries
aries211
 
Posts: 11
Joined: Wed Mar 29, 2006 9:32 am
Location: China

Postby aries211 » Sun Apr 30, 2006 10:15 am

My God !

The same error occurs again :?:
aries211
 
Posts: 11
Joined: Wed Mar 29, 2006 9:32 am
Location: China

Postby red1 » Sun Apr 30, 2006 12:18 pm

I got somewhat similar issues before when using older Java 1.4 instead of Java 5. U have to use Java 5 to compile.

In Eclipse u have to go to top menu bar > Window > Preferences > Java > Compiler . to make sure its Java 5.

U can have both Java JREs installed on same machine. Just do the switching as above and in the properties of the source.
red1
Site Admin
 
Posts: 2740
Joined: Tue Jul 06, 2004 3:01 pm
Location: Kuala Lumpur, Malaysia

Postby aries211 » Mon May 08, 2006 9:24 am

Hi. red1

I'm using Java 5

Regards
aries211
 
Posts: 11
Joined: Wed Mar 29, 2006 9:32 am
Location: China

Postby Mr_reggatta » Mon May 08, 2006 11:16 pm

From eclipse...
you can try to delete librarys and then re-import...
i had your same problem and now i have resolved!
;-)
Mr_reggatta
 
Posts: 24
Joined: Wed Mar 15, 2006 12:34 am
Location: Roma, Italy


Return to BUGS Galore!

Who is online

Users browsing this forum: No registered users and 1 guest

cron