Page 1 of 1

build compiere from eclipse

PostPosted: Mon Jul 24, 2006 2:45 pm
by kiki2000
hi,
i try to build compiere 253 from eclipse and when i imported compiere-all i have 100 errors, like :

Syntax error, annotations are only available if source level is 5.0


please help me how can'i correct them and where i found eclipsefiles for release 253.
thanks

PostPosted: Mon Jul 24, 2006 4:43 pm
by karsten-thiemann
Hi,

it seems that you compile it with java 1.4 (or lower) instead of 1.5 (5.0). To change that you need to install the JDK 5.0 from here http://java.sun.com/javase/downloads/index.jsp.
Than you go (in eclipse) to window->preferences->java->compiler and set the complience level to 5.0.
You also have to add the installed JDK under window->preferences->java->Installed JREs and set it as default (first checkbox).

Hope that helps...

PostPosted: Mon Jul 24, 2006 5:21 pm
by kiki2000
thanksssss for you
I forgot this stages :
window->preferences->java->compiler and set the complience level to 5.0.

I want to know the version installed in my computer is 252e.and I want build the version 253d from eclipse; but when i run my project this error appears : User does not match password.
is necessary it to make Run_setup from eclipse

PostPosted: Tue Jul 25, 2006 10:57 am
by red1
User does not match password is info stored in the AD_User table of the DB and not the source.

U cant cross version on your own. For 253 thats the latest, u have to synch with the compiere CVS in sourceforge, but it will have errors, and u need to know abit about java and source to solve that.